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to make improvements in the products described in this manual at any time without
notice. No part of this manual may be reproduced, copied, translated or transmitted
in any form or by any means without the prior written permission of Advantech Co.,
Ltd. Information provided in this manual is intended to be accurate and reliable.
However, Advantech Co., Ltd. assumes no responsibility for its use, nor for any
infringements of the rights of third parties, which may result from its use.
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Product Warranty (5 years)
Advantech warrants to you, the original purchaser, that each of its products will be
free from defects in materials and workmanship for five years from the date of
purchase.

This warranty does not apply to any products which have been repaired or altered by
persons other than repair personnel authorized by Advantech, or which have been
subject to misuse, abuse, accident or improper installation. Advantech assumes no
liability under the terms of this warranty as a consequence of such events.

Because of Advantech’s high quality-control standards and rigorous testing, most of
our customers never need to use our repair service. If an Advantech product is
defective, it will be repaired or replaced at no charge during the warranty period. For
out of-warranty repairs, you will be billed according to the cost of replacement
materials, service time and freight. Please consult your dealer for more details.

If you think you have a defective product, follow these steps:

1. Collect all the information about the problem encountered. (For example, CPU 
speed, Advantech products used, other hardware and software used, etc.) Note 
anything abnormal and list any on screen messages you get when the problem 
occurs.

2. Call your dealer and describe the problem. Please have your manual, product, 
and any helpful information readily available.

3. If your product is diagnosed as defective, obtain an RMA (return merchandize 
authorization) number from your dealer. This allows us to process your return 
more quickly.

4. Carefully pack the defective product, a fully-completed Repair and Replacement 
Order Card and a photocopy proof of purchase date (such as your sales receipt) 
in a shippable container. A product returned without proof of the purchase date 
is not eligible for warranty service.

5. Write the RMA number visibly on the outside of the package and ship it prepaid 
to your dealer.

Part No. 2009122X00 Edition 1

Printed in Taiwan October 2018
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Declaration of Conformity

CE

This product has passed the CE test for environmental specifications. Test conditions
for passing included the equipment being operated within an industrial enclosure. In
order to protect the product from being damaged by ESD (Electrostatic Discharge)
and EMI leakage, we strongly recommend the use of CE-compliant industrial
enclosure products.

FCC Class A

Note: This equipment has been tested and found to comply with the limits for a Class
A digital device, pursuant to part 15 of the FCC Rules. These limits are designed to
provide reasonable protection against harmful interference when the equipment is
operated in a commercial environment. This equipment generates, uses, and can
radiate radio frequency energy and, if not installed and used in accordance with the
instruction manual, may cause harmful interference to radio communications.
Operation of this equipment in a residential area is likely to cause harmful
interference in which case the user will be required to correct the interference at his
own expense.

Technical Support and Assistance
1. Visit the Advantech web site at www.advantech.com/support where you can find 

the latest information about the product.
2. Contact your distributor, sales representative, or Advantech's customer service 

center for technical support if you need additional assistance. Please have the 
following information ready before you call:
– Product name and serial number
– Description of your peripheral attachments
– Description of your software (operating system, version, application software, 

etc.)
– A complete description of the problem
– The exact wording of any error messages
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Warnings, Cautions, and Notes

Document Feedback
To assist us in making improvements to this manual, we would welcome comments
and constructive criticism. Please send all such - in writing to: 
support@advantech.com

Packing List
Before setting up the system, check that the items listed below are included and in
good condition. If any item does not accord with the table, please contact your dealer
immediately.

 1 x Modbus router
 1 x DIN-Rail mounting bracket and screws
 1 x Wall-mounting bracket

Warning! Warnings indicate conditions, which if not observed, can cause personal 
injury!

Caution! Cautions are included to help you avoid damaging hardware or losing 
data. e.g.

There is a danger of a new battery exploding if it is incorrectly installed. 
Do not attempt to recharge, force open, or heat the battery. Replace the 
battery only with the same or equivalent type recommended by the man-
ufacturer. Discard used batteries according to the manufacturer's 
instructions.

Note! Notes provide optional additional information.
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Safety Instructions
 Read these safety instructions carefully.
 Keep this User Manual for later reference.
 Disconnect this equipment from any DC outlet before cleaning. Use a damp 

cloth. Do not use liquid or spray detergents for cleaning.
 For plug-in equipment, the power outlet socket must be located near the 

equipment and must be easily accessible.
 Keep this equipment away from humidity.
 Put this equipment on a reliable surface during installation. Dropping it or letting 

it fall may cause damage.
 The openings on the enclosure are for air convection. Protect the equipment 

from overheating. DO NOT COVER THE OPENINGS.
 Make sure the voltage of the power source is correct before connecting the 

equipment to the power outlet.
 Position the power cord so that people cannot step on it. Do not place anything 

over the power cord.
 All cautions and warnings on the equipment should be noted.
 If the equipment is not used for a long time, disconnect it from the power source 

to avoid damage by transient overvoltage.
 Never pour any liquid into an opening. This may cause fire or electrical shock.
 Never open the equipment. For safety reasons, the equipment should be 

opened only by qualified service personnel.
 If one of the following situations arises, get the equipment checked by service 

personnel:
– The power cord or plug is damaged.
– Liquid has penetrated into the equipment.
– The equipment has been exposed to moisture.
– The equipment does not work well, or you cannot get it to work according to 

the user's manual.
– The equipment has been dropped and damaged.
– The equipment has obvious signs of breakage.

 DO NOT LEAVE THIS EQUIPMENT IN AN ENVIRONMENT WHERE THE 
STORAGE TEMPERATURE MAY GO -40°C (-40°F) ~ 85°C (185°F). THIS 
COULD DAMAGE THE EQUIPMENT. THE EQUIPMENT SHOULD BE IN A 
CONTROLLED ENVIRONMENT.

 The sound pressure level at the operator's position according to IEC 704-1:1982 
is no more than 70 dB (A).
DISCLAIMER: This set of instructions is given according to IEC 704-1.
Advantech disclaims all responsibility for the accuracy of any statements
contained herein.

 The device is used for the restricted access location.
 WARNING: USE CONDUCTORS WITH INSULATION RATED FOR AT LEAST 

75°C.
AVERTISSEMENT : EMPLOYER DES CONDUCTEURS POUR AU MOINS 
75°C.

 BASE THE CONDUCTOR AMPACITY ON A MAXIMUM TERMINATION 
TEMPERATURE OF 75°C.
LE COURANT ADMISSIBLE DU CONDUCTEUR DOIT ÊTRE DÉTERMINÉ EN 
FONCTION D'UNE TEMPÉRATURE MAXIMALE AUX TERMINAISONS DE 
75°C.
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 CAUTION: FOR USE IN A CONTROLLED ENVIRONMENT. REFER TO 
MANUAL FOR ENVIRONMENTAL CONDITIONS.
ATTENTION : POUR UTILISATION EN ATMOSPHÈRE CONTRÔLÉE. 
CONSULTER LA NOTICE TECHNIQUE.

 WARNING: EKI-1242 IS LIVE. RISK OF ELECTRIC SHOCK. DISCONNECT 
POWER BEFORE SERVICING.
AVERTISSEMENT : EKI-1242 EST SOUS TENSION. RISQUE DE CHOC 
ÉLECTRIQUE, COUPER LE COURANT AVANT L'ENTRETIEN.

 WARNING: DISCONNECT ALL SOURCES OF SUPPLY BEFORE 
SERVICING.
AVERTISSEMENT : COUPER TOUTES LES SOURCES D'ALIMENTATION 
AVANT DE FAIRE L'ENTRETIEN ET LES RÉPARATIONS.

 NEUTRAL FLOATING.
NEUTRE FLOTTANT.

 IMPORTANT SAFETY INSTRUCTIONS
INSTRUCTIONS IMPORTANTES CONCERNANT LA SÉCURITÉ
– SAVE THESE INSTRUCTIONS - THIS MANUAL CONTAINS IMPORTANT 

SAFETY INSTRUCTIONS.
CONSERVER CES INSTRUCTIONS. CETTE NOTICE CONTIENT DES 
INSTRUCTIONS IMPORTANTES CONCERNANT LA SÉCURITÉ.

 WARNING: SHOCK HAZARD. ONLY FOR MOUNTING IN A RACK OR 
ENCLOSURE FULLY ENCLOSING ALL LIVE PARTS.
AVERTISSEMENT : RISQUE D'ÉLECTROCUTION. NE DOIT ÊTRE INSTALLÉ 
QUE DANS UN BÂTI OU UN BOÎTIER RECOUVRANT ENTIÈREMENT 
TOUTES LES PIÈCES SOUS TENSION.

 WARNING: HOT SURFACE.
AVERTISSEMENT : SURFACE CHAUDE.

 WARNING: PROPER VENTILATION IS REQUIRED TO REDUCE THE RISK 
OF HAZARDOUS OR EXPLOSIVE GAS BUILDUP DURING INDOOR 
CHARGING. SEE OWNERS MANUAL.
AVERTISSEMENT : UNE VENTILATION ADÉQUATE EST NÉCESSAIRE AFIN 
DE RÉDUIRE LES RISQUES D'ACCUMULATION DE GAZ DANGEREUX OU 
EXPLOSIFS DURANT LA RECHARGE À L'INTÉRIEUR. VOIR LE MANUEL 
D'ENTRETIEN.

 FOR USE WITH COPPER CONDUCTORS ONLY.
DESTINÉ À ÊTRE UTILISÉ AVEC DES CONDUCTEURS EN CUIVRE 
SEULEMENT.

 WARNING: HOT SURFACE(S).
AVERTISSEMENT : SURFACE(S) CHAUDE(S).
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Safety Precaution - Static Electricity
Static electricity can cause bodily harm or damage electronic devices. To avoid
damage, keep static-sensitive devices in the static-protective packaging until the
installation period. The following guidelines are also recommended:

 Wear a grounded wrist or ankle strap and use gloves to prevent direct contact 
with the device before servicing the device. Avoid nylon gloves or work clothes, 
which tend to build up a charge.

 Always disconnect the power from the device before servicing it.
 Before plugging a cable into any port, discharge the voltage stored on the cable 

by touching the electrical contacts to the ground surface.
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Chapter 1

1Product Overview



 

1.1 Specifications

Specifications Description

Interface I/O Port  EKI-1221R-CE: 2 x Ethernet + 1 RS-232/422/
485

 EKI-1222R-CE: 2 x Ethernet + 2 RS-232/422/
485

 EKI-1224R-CE: 2 x Ethernet + 4 RS-232/422/
485

Power Connector 6-pin removable screw terminal (power & relay)

Physical Enclosure Metal with solid mounting hardware

Installation DIN-rail, wall mount

Dimensions 
(W x H x D)

 EKI-1221R-CE: 30 x 140 x 95 mm (1.19” x 5.52” 
x 3.75”)

  EKI-1222R-CE: 30 x 140 x 95 mm (1.19” x 
5.52” x 3.75”)

 EKI-1224R-CE: 42 x 140 x 95 mm (1.66” x 5.52” 
x 3.75”)

LED Display System LED P1, P2, Status

Port LED  LAN: Speed, Link/Active

 Serial: Tx, Rx

Environment Operating 
Temperature

-10°C ~ 60°C (14°F ~ 140°F)

Storage 
Temperature

-40°C ~ 85°C (-40°F ~ 185°F)

Ambient Relative 
Humidity

5 ~ 95% (non-condensing)

Power Power 
Consumption

 EKI-1221R-CE: 3.2W

  EKI-1222R-CE: 3.2W

 EKI-1224R-CE: 4.1W

Power Input 12 ~ 48 VDC, redundant dual power inputs

Certifications EMC CE, FCC Part 15 Subpart B (Class A)
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1.2 Hardware Views

1.2.1 Front View

1.2.1.1 EKI-1221R-CE

Figure 1.1 Front View

No. Item Description

1 System LED panel See “LED Indicators” on page 9 for further details.

2 Default Press to restart the device. Press and hold 10 seconds to reset 
to factory default.

3 ETH ports RJ45 ports for Ethernet.

4 Serial port DB9 pinout supports RS232/422/485.
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Default

Ethernet ports
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TH

1/W
A

N
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2

TxRx

P1 P2 Status

S
erial port

EKI-1221R

3

4

1
2
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1.2.1.2 EKI-1222R-CE

Figure 1.2 Front View

No. Item Description

1 System LED panel See “LED Indicators” on page 9 for further details.

2 Default Press to restart the device. Press and hold 10 seconds to reset 
to factory default.

3 ETH ports RJ45 ports for Ethernet.

4 Serial ports DB9 pinout supports RS232/422/485.

1

2
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Ethernet ports
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erial ports
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1.2.1.3 EKI-1224R-CE

Figure 1.3 Front View

No. Item Description

1 System LED panel See “LED Indicators” on page 9 for further details.

2 Default Press to restart the device. Press and hold 10 seconds to reset 
to factory default.

3 ETH ports RJ45 ports for Ethernet.

4 Serial ports DB9 pinout supports RS232/422/485.

1
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Default

TxRx

TxRx

TxRx

TxRx

P1 P2 Status

Serial ports

EKI-1224R

Ethernet ports

ETH
1/ W

AN
ETH

2

1
2

3

4
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1.2.2 Rear View

1.2.2.1 EKI-1221R-CE/EKI-1222R-CE

Figure 1.4 Rear View

No. Item Description

1 DIN-Rail mounting 
plate

Mounting plate used for the installation to a standard DIN rail.

1
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1.2.2.2 EKI-1224R-CE

Figure 1.5 Rear View

1.2.3 Top View

1.2.3.1 EKI-1221R-CE/EKI-1222R-CE

Figure 1.6 Top View

No. Item Description

1 DIN-Rail mounting 
plate

Mounting plate used for the installation to a standard DIN rail.

1

No. Item Description

1 Wall mounting 
screws

Screws (x4) used in the installation of a wall mounting plate.

2 Terminal block Connect cabling for power and alarm wiring.

3 Ground terminal Screw terminal used on ground chassis.

PWR2

P-Fail

DC12-48VPWR1

V2-   V2+ V1-   V1+

1A@24V

2

1 3
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1.2.3.2 EKI-1224R-CE

Figure 1.7 Top View

1.2.4 Bottom View

1.2.4.1 EKI-1221R-CE/EKI-1222R-CE

Figure 1.8 Bottom View

1.2.4.2 EKI-1224R-CE

Figure 1.9 Bottom View

No. Item Description

1 Wall mounting 
screws

Screws (x4) used in the installation of a wall mounting plate.

2 Terminal block Connect cabling for power and alarm wiring.

3 Ground terminal Screw terminal used on ground chassis.

PWR2

P-Fail

DC12-48VPWR1

V2-   V2+ V1-   V1+

1A@24V

2

1 3

No. Item Description

1 Wall mounting 
screws

Screws (x4) used in the installation of a wall mounting plate.

1

No. Item Description

1 Wall mounting 
screws

Screws (x4) used in the installation of a wall mounting plate.

1
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1.2.5 LED Indicators

1.3 Dimensions

Figure 1.10 Dimensions (EKI-1221R-CE)

LED Name LED Color Description

P1 Green Power 1 is on

Off Power 1 is off or power error condition exists

P2 Green Power 2 is on

Off Power 2 is off or power error condition exists

Status Amber The device is located using the location function in utility

Blinking System is ready

Off System is powered off

WAN/Ethernet2 Amber On: 100Mbps Ethernet connection
Off: 10Mbps Ethernet connection

Green Blinking: Ethernet port is transmitting or receiving data
Steady on: Ethernet has a good link for 10Mbps or 100Mbps 
operations

Serial Amber Serial port is receiving data

Green Serial port is transmitting data

Off Data is not transmitted or received through the serial port
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Figure 1.11 Dimensions (EKI-1222R-CE)

Figure 1.12 Dimensions (EKI-1224R-CE)
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Chapter 2

2Modbus Router 
Installation



 

2.1 Installation Guidelines
The following guidelines are provided to optimize the device performance. Review
the guidelines before installing the device.

 Make sure cabling is away from sources of electrical noise. Radios, power lines, 
and fluorescent lighting fixtures can interference with the device performance.

 Make sure the cabling is positioned away from equipment that can damage the 
cables.

 Operating environment is within the ranges listed range, see “Specifications” on 
page 2.

 Relative humidity around the modbus router does not exceed 95 percent 
(noncondensing).

 Altitude at the installation site is not higher than 10,000 feet.
 In 10/100 fixed port devices, the cable length from the modbus router to 

connected devices cannot exceed 100 meters (328 feet).
 Make sure airflow around the modbus router and respective vents are 

unrestricted. Without proper airflow, the modbus router can overheat. To prevent 
performance degradation and damage to the modbus router, make sure there is 
clearance at the top and bottom and around the exhaust vents. 

2.1.1 Connecting Hardware
In this instruction, it will explain how to find a proper location for your Modbus
Routers, and how to connect to the network, hock up the power cable, and connect to
the EKI-122xR-CE Series.

2.2 Verifying Modbus Router Operation
Before installing the device in a rack or on a wall, power on the modbus router to
verify that the modbus router passes the power-on self-test (POST). To connect the
cabling to the power source see “Power Supply Installation” on page 18. 

At startup (POST), the System LED blinks green, while the remaining LEDs are a
solidy green. Once the modbus router passes POST self-test, the System LED turns
green. The other LEDs turn off and return to their operating status. If the modbus
router fails POST, the System LED modbus routers to an amber state.

After a successful self-test, power down the modbus router and disconnect the power
cabling. 

The modbus router is now ready for installation on its final location.
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2.3 Installing the Modbus Router

2.3.1 DIN Rail Mounting
The DIN rail mount option is the quickest installation option. Additionally, it optimizes
the use of rail space.

The metal DIN rail kit is secured to the rear of the modbus router. The device can be
mounted onto a standard 35 mm (1.37”) x 7.5 mm (0.3”) height DIN rail. The devices
can be mounted vertically or horizontally. Refer to the following guidelines for further
information.

2.3.1.1 Installing the DIN-Rail Mounting Kit
1. Position the rear panel of the modbus router directly in front of the DIN rail, 

making sure that the top of the DIN rail clip hooks over the top of the DIN rail, as 
shown in the following illustration.

Make sure the DIN rail is inserted behind the spring mechanism.

2. Once the DIN rail is seated correctly in the DIN rail clip, press the front of the 
modbus router to rotate the modbus router down and into the release tab on the 
DIN rail clip. 
If seated correctly, the bottom of the DIN rail should be fully inserted in the
release tab.

Figure 2.1 Installing the DIN-Rail Mounting Kit

Note! A corrosion-free mounting rail is advisable.

When installing, make sure to allow for enough space to properly install 
the cabling.

Warning! Do not install the DIN rail under or in front of the spring mechanism on 
the DIN rail clip to prevent damage to the DIN rail clip or the DIN rail.

DIN rail clip

DIN rail

DIN rail clip
release tab
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See the following figure for an illustration of a completed DIN installation
procedure.

Figure 2.2 Correctly Installed DIN Rail Kit

3. Grasp the bottom of the modbus router and slightly rotate it upwards. If there is 
resistance, the modbus router is correctly installed. Otherwise, re-attempt the 
installation process from the beginning.

2.3.1.2 Removing the DIN-Rail Mounting Kit
1. Ensure that power is removed from the modbus router, and disconnect all 

cables and connectors from the front panel of the modbus router.
2. Push down on the top of the DIN rail clip release tab with your finger. As the clip 

releases, lift the bottom of the modbus router, as shown in the following 
illustration.

\

Figure 2.3 Removing the DIN-Rail
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2.3.2 Wall-Mounting
The wall mounting option provides better shock and vibration resistance than the DIN
rail vertical mount.

Before the device can be mounted on a wall, you will need to remove the DIN rail
plate.

1. Rotate the device to the rear side and locate the DIN mounting plate.
2. Remove the screws securing the DIN mounting plate to the rear panel of the 

modbus router.
3. Remove the DIN mounting plate. Store the DIN mounting plate and provided 

screws for later use.
4. Remove the screws securing on the top and bottom of the device.
5. Align the wall mounting plates on the rear side. The screw holes on the device 

and the mounting plates must be aligned, see the following illustration.
6. Secure the wall mount plates with the provided screws, see the following figure.

Figure 2.4 Installing Wall Mount Plates

Note! When installing, make sure to allow for enough space to properly install 
the cabling.
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Once the wall mounting plates are secure on the device, you will need to attach the
wall screws (x4).

7. Locate the installation site and place the modbus router against the wall, making 
sure it is the final installation location.

8. Use the wall mount plates as a guide to mark the locations of the screw holes.
9. Drill four holes over the four marked locations on the wall, keeping in mind that 

the holes must accommodate wall sinks in addition to the screws.
To mount the wall plate, use screws of the size shown in the following
illustration.

Figure 2.5 Wall Mounting Screw Dimensions

10. Align the wall mount plate over the screws on the wall.
11. Install the wall mount plate on the screws and slide it forward to lock in place, 

see the following figure.

Figure 2.6 Wall Mount Installation

12. Once the device is installed on the wall, tighten the screws to secure the device.

Note! Make sure you use the recommended screw length for your particular 
application. The screws need to penetrate properly for the rated weight 
rating.

8.0 mm

4.0 mm

2

2

1
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2.4 Connecting the Modbus Router to Ethernet 
Ports

2.4.1 RJ45 Ethernet Cable Wiring
For RJ45 connectors, data-quality, twisted pair cabling (rated CAT5 or better) is
recommended. The connector bodies on the RJ45 Ethernet ports are metallic and
connected to the GND terminal. For best performance, use shielded cabling.
Shielded cabling may be used to provide further protection.

Figure 2.7 Ethernet Plug & Connector Pin Position

Maximum cable length: 100 meters (328 ft.) for 10/100BaseT.

2.5 Serial Connection
EKI-122xR-CE Series provides eight ports DB9 (male) connectors. RS-232/422/485
pin assignments as below:

Figure 2.8 DB 9 Pin Position

Straight-thru Cable Wiring Cross-over Cable Wiring

Pin 1 Pin 1 Pin 1 Pin 3

Pin 2 Pin 2 Pin 2 Pin 6

Pin 3 Pin 3 Pin 3 Pin 1

Pin 6 Pin 6 Pin 6 Pin 2

1

8

Pin 1 2 3 4 5 6 7 8 9

RS-232 DCD RX TX DTR GND DSR RTS CTS RI

RS-422 TX- TX+ GND RX+ RX-

RS-485 DATA- DATA+ GND

5
9

1
6
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2.6 Power Supply Installation

2.6.1 Overview

The modbus routers can be powered by using the same DC source used to power
other devices. A DC voltage range of 12 to 48 VDC must be applied between the V1+
terminal and the V1- terminal (PW1), see the following illustrations. The chassis
ground screw terminal should be tied to the panel or chassis ground. A redundant
power configuration is supported by a secondary power supply unit to reduce
network downtime as a result of power loss.

EKI-122xR-CE Series support 12 to 48 VDC. Dual power inputs are supported and
allow you to connect a backup power source.

Figure 2.9 Power Wiring for EKI-122xR-CE Series

Warning! Power down and disconnect the power cord before servicing or wiring 
the modbus router.

Caution! Do not disconnect modules or cabling unless the power is first switched 
off.

The device only supports the voltage outlined in the type plate. Do not 
use any other power components except those specifically designated 
for the modbus router device.

Caution! Disconnect the power cord before installation or cable wiring. 

P2 P1

Chassis
GND

(pane)

One DC Supply

P2 P1

Chassis
GND

(pane)

Dual DC Supplies

Single DC Power Redundant DC Power
18 EKI-122xR-CE Series User Manual



2.6.2 Considerations
Take into consideration the following guidelines before wiring the device:

 The Terminal Block (CN1) is suitable for 12-24 AWG (3.31 - 0.205 mm2). Torque 
value 7 lb-in.

 The cross-sectional area of the earthing conductors shall be at least 3.31 mm2.
 Calculate the maximum possible current for each power and common wire. 

Make sure the power draw is within limits of local electrical code regulations. 
 For best practices, route wiring for power and devices on separate paths.
 Do not bundle together wiring with similar electrical characteristics.
 Make sure to separate input and output wiring.
 Label all wiring and cabling to the various devices for more effective 

management and servicing.

2.6.3 Grounding the Device

Note! Routing communications and power wiring through the same conduit 
may cause signal interference. To avoid interference and signal 
degradation, route power and communications wires through separate 
conduits.

Caution! Do not disconnect modules or cabling unless the power is first switched 
off.

The device only supports the voltage outlined in the type plate. Do not 
use any other power components except those specifically designated 
for the modbus router device.

Caution! Before connecting the device properly ground the device. Lack of a 
proper grounding setup may result in a safety risk and could be 
hazardous.

Caution! Do not service equipment or cables during periods of lightning activity.

Caution! Do not service any components unless qualified and authorized to do 
so.

Caution! Do not block air ventilation holes.
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Electromagnetic Interference (EMI) affects the transmission performance of a device.
By properly grounding the device to earth ground through a drain wire, you can set
up the best possible noise immunity and emissions.

Figure 2.10 Grounding Connection

By connecting the ground terminal by drain wire to earth ground the modbus router
and chassis can be ground.

2.6.4 Wiring a Relay Contact
The following section details the wiring of the relay output. The terminal block on the
EKI-122xR-CE Series is wired and then installed onto the terminal receptor located
on the EKI-122xR-CE Series.

Figure 2.11 Terminal Receptor: Relay Contact

The terminal receptor includes a total of six pins: two for PWR1, two for PWR2 and
two for a fault circuit.

2.6.5 Wiring the Power Inputs

Note! Before applying power to the grounded modbus router, it is advisable to 
use a volt meter to ensure there is no voltage difference between the 
power supply’s negative output terminal and the grounding point on the 
modbus router.

PWR2

P-Fail

DC12-48V PWR1

V2-   V2+V1-   V1+

1A@24V

Drain Wire with Lug

Connection to 
Grounding Point

PWR2

P-Fail

DC12-48VPWR1

V2-   V2+ V1-   V1+

1A@24V

Caution! Do not disconnect modules or cabling unless the power is first switched 
off.

The device only supports the voltage outlined in the type plate. Do not 
use any other power components except those specifically designated 
for the modbus router device.

Warning! Power down and disconnect the power cord before servicing or wiring 
the modbus router.
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There are two power inputs for normal and redundant power configurations. The
power input 2 is used for wiring a redundant power configuration. See the following
for terminal block connector views.

Figure 2.12 Terminal Receptor: Power Input Contacts

To wire the power inputs:

Make sure the power is not connected to the modbus router or the power converter
before proceeding.

1. Loosen the screws securing terminal block to the terminal block receptor.
2. Remove the terminal block from the modbus router.

Figure 2.13 Removing a Terminal Block

3. Insert a small flat-bladed screwdriver in the V1+/V1- wire-clamp screws, and 
loosen the screws.

4. Insert the negative/positive DC wires into the V+/V- terminals of PW1. If setting 
up power redundancy, connect PW2 in the same manner.

5. Tighten the wire-clamp screws to secure the DC wires in place.

Figure 2.14 Installing DC Wires in a Terminal Block

PWR2

P-Fail

DC12-48VPWR1

V2-   V2+ V1-   V1+

1A@24V

Loosening
Wire-clamp
Screws

Installing DC
Wires

Securing
Wire-clamp
Screws
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6. Align the terminal block over the terminal block receptor on the modbus router.
7. Insert the terminal block and press it in until it is flush with the terminal block 

receptor.
8. Tighten the screws on the terminal block to secure it to the terminal block 

receptor.
If there is no gap between the terminal block and the terminal receptor, the
terminal block is seated correctly.

Figure 2.15 Securing a Terminal Block to a Receptor

2.7 Default Button
Reset configuration to factory default:

Press and hold the Default button for 10 seconds.

System reboot:

Press the Default button.

Note! Do NOT power off the modbus router when loading default settings.
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Chapter 3

3Configuration



3.1 Configuration Utility Overview
Advantech EKI series modbus routers provide an easy-to-use utility to configure your
modbus router through an Ethernet connection. For secure administration, it can also
restrict the access rights for configuration to only one host PC. With this secure func-
tion enabled, other PCs will not have permission for configuration. After the installa-
tion program on the Advantech EKI Device Configuration Utility CD-ROM is finished,
the modbus routers are ready for use and configuration.

Advantech EKI Device Configuration Utility is an excellent modbus router manage-
ment tool. You can connect and configure the local and remote Advantech modbus
routers easily. The utility provides access to the following functions:

 Configure the network settings (you can set the IP address, Gateway address, 
and Subnet mask)

3.2 Installing the Configuration Utility

1. Insert the Advantech EKI Device Configuration Utility CD-ROM into the CD-
ROM drive (whereas E:\ is the drive name of your CD-ROM) on the host PC.

2. Use Windows explorer or the Windows Run command to execute the setup pro-
gram.

3. If there is an existing COM port mapping utility on the host PC, remove it at this 
time. A system reboot may be necessary before continuing the installation.

4. Once the InstallShield Wizard screen displays, click Next to proceed with the 
installation.

Figure 3.1 InstallShield Wizard 1 of 4

Note! Microsoft .NET Framework version 2.0 or greater is required for this 
application.
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5. The Software License Agreement displays, press I Agree to continue or Cancel 
to stop the installation.

Figure 3.2 InstallShield Wizard 2 of 4

The InstallShield continues and a status screen displays. The default installation
path is C:\Program Files\EKI Device Configuration Utility.

Figure 3.3 InstallShield Wizard 3 of 4
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6. Once the installation of the package is finished a Configuration Utility Setup 
screen displays. Click Finish to conclude the process and exit the InstallShield 
Wizard.

Figure 3.4 InstallShield Wizard 4 of 4
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3.3 Menu Bar
You can open the Configuration Utility from the Windows Start Menu by clicking Start
> All Programs > EKI Device Configuration Utility > EKI Device Configuration
Utility. The Configuration Utility displays as shown in the following figure.

Figure 3.5 Configuration Utility Overview

No Item Description

1 Menu Bar Displays File, View, Management, Tools and Help.

2 Quick Tool Bar Useful management functions shortcuts.

3 Device List Area Available devices are listed in this area. Devices and COM ports 
can be organized or grouped in this area.

4 Information Panel Click on the devices or move cursor to the devices, the related 
information is shown in this area.

5 Status Bar Displays the current time.

6 Configuration Area Click on the item on the Device List Area, the configuration page 
displays. 

5

4

3

2

6

1
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3.4 Quick Tool Bar
The Advantech EKI Device Configuration Utility makes use of a Quick Tool Bar menu
to allow quick access to the management functions. See the following figure for fur-
ther information.

Figure 3.6 Quick Tool Bar Overview

Icon Item Description

Utility Settings Clear to configure the general settings for the Main Form 
Setting and Device Manager menus.
 Refer to “Utility Settings” on page 30.

Configuration Wizard Start the software wizard (setup assistant) to lead you 
through the VCOM configuration process for modbus 
router product.

Clear Device List and 
Search Again

Click to clear listed modbus routers in the Device List 
Area and initiate a new search.
A continuous click of the icon results in the following 
message: Please do not refresh so frequently.

Search Again Click to search for modbus routers on the local LAN.

Add IP Address to 
Favorite

Click to include the selected IP Address into the Favor-
ites list group.

Search for a Range 
of IP Addresses

Click to begin a range search. Enter the beginning and 
ending IP addressed to being a search within the string 
parameters. 

Manual Direct Map-
ping Virtual COM 
Port

Click to add a target by selecting the Device Type and 
inputting the IP address without physically connecting 
the modbus router to the network.
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3.4.1 Utility Settings

3.4.1.1 Main Form Setting
Click View > Settings to configure utility settings.

Figure 3.7 View > Settings > Main Form Setting

Item Description

Main Window Settings

Maximum Main Window 
On Load

Check the box to enable the limiting of main windows on-load to 
the maximum value.

Log Settings

Show Log Message Win-
dow

Check the check box to activate the AdvLogMessage form. The 
Form Log message displays. 

Save Log to File Check the check box to save log to file.

Browse If the Save Log to File option is enabled, click Browse to select a 
file to save log data. 

Language Settings

Interface Language Click the drop-down menu to select an interface language: Tradi-
tional Chinese, Simplified Chinese or English.

NOTE: A restart is required for the settings to take effect.

OK Click OK to save and exit the Utility Settings menu.

Cancel Click Cancel to discard the changes.

Apply Click Apply to save the main form settings.
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3.4.1.2 Device Manager

Figure 3.8 View > Settings > Device Manager

Item Description

Device Manager

Tree View Grouping Click the drop-down menu to enable or disable grouping.

Show Empty Device Type 
Node

Check the check box to show empty device type node or not.

Expand New Appended 
Device Node

Check the check box to expand a new appended device node.

Device Auto Detection

After utility ready, start 
auto detection after X sec-
ond

Enter a value to specify the time to auto detection time (-1 
means disable auto detection).

Auto detect devices every 
X second

Enter a value to specify the time to auto detect devices.

Check device alive every 
X second

Enter a value to specify the time to check device alive.

Mark device as lost con-
tact after retry for X times

Enter a value to specify the time to mark device as lost contact.

Unsigned Hardware Installation

Automatic answer for 
unsigned hardware instal-
lation

Check the check box to enable or disable answer automatically 
for unsigned hardware installation.

OK Click OK to save and exit the utility setting.

Cancel Click Cancel to discard the changes.

Apply Click Apply to save the utility setting.
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3.4.2 Discovering Your Modbus Router

3.4.2.1 Auto Searching
Advantech EKI Device Configuration Utility will automatically search all the EKI-
122xR-CE Series modbus routers on the network and show them on the Device List
Area of the utility. The utility provides an auto-search function to show your device (s)
by simply executing the configuration utility program from the Start Menu.

From here all devices on the same network domain will be searched and displayed
on Device List Area. You can click on a device name to show the features of the spe-
cific device. 

Click on the “+” before the model name, and the utility will expand the tree structure
to show the individual device name. Click on the “-” before the model name, and the
utility will collapse the tree structure.

Figure 3.9 Open View of Device Configuration Utility

In the previous figure, the EKI modbus router is listed as EKI-1224R-CE-B12D1B.

Select the device in this sub-tree. The first tab on the Configuration Area shows the
summary of “Basic Information” included device type, version, and name, “Ethernet

Note! When you run the configuration utility for the first time, the default device 
name is obtained from the device’s MAC identification number. The 
name can be altered through the configuration utility.
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Information”, and “Serial Port Information”. In the serial port information frame, it dis-
plays the operation mode, status and connected host IP.

Figure 3.10 Selecting a Group

Click on the “+” before the device name, and the utility will expand the interfaces on
this modbus router.

Figure 3.11 Selecting a Device

Click on each item to enter the configuration page to change the setting. The configu-
ration will be introduced on following sections.

Figure 3.12 Viewing Basic Settings
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3.4.3 Network Settings
This section explains how to configure the EKI-122xR-CE Series network settings
using the configuration utility to allow it to a device over a network connection.

Click on the “+” before the model name (e.g. EKI-1222) to expand the device’s sub-
menu listing. Click on the “+” before the device name, and the utility expands the
interfaces on the modbus router.

Select the Ethernet interface (Eth2) to view the settings and modify them.

Figure 3.13 Utility Overview
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You can choose from four possible IP Configuration modes --- Static and DHCP.

Figure 3.14 Network Settings Overview

Item Description

Static IP User defined IP address, Subnet Mask, and Default Gateway.

DHCP DHCP Server assigned IP address, Subnet Mask, and Default 
Gateway.

Note! When you have finished the configuration of these settings for each cat-
egory, please press the “Apply” button in order to make these settings 
effective on the modbus router.
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Click Reset Device to reboot the modbus router. Any configuration changes you
have made since the last time you saved will be lost.

To reset the device:

1. Right-click a desired device to display the settings menu.
2. Select Reset Device.

Figure 3.15 Reset Device
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3.5 Administrator Settings

3.5.1 Locate the Modbus Router
When several modbus routers are connected to the network, identification of a spe-
cific device is possible through the Locate function.

To locate the modbus router:

1. From the device list frame, locate the desired device and right-click on it to dis-
play the settings menu.

2. Select Locate from the menu.

Figure 3.16 Locate the Modbus Router

The unit’s Status LED solid amber and the buzzer beep until you click Stop Locate.
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3.5.2 Restore to Factory Default Settings
The configuration utility provides the function to restore the modbus router to factory
default settings. 

Figure 3.17 Restore to Factory Default Settings

The confirm message will display after clicking Restore to Factory Default Set-
tings. If you really want to restore the modbus router to factory default settings, click
Yes button to continue.

Power off the modbus router within ten seconds. After reconnecting the power, all
settings will be reset to the factory default. If the power supply remains connected for
more than ten seconds, the modbus router will not be changed.
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3.5.3 Resetting the Device
The Reset Device function allows you to reset the modbus router. The function dis-
connects both the ethernet and serial connections.

The function also allows the modbus router to save new configuration settings to
flash memory. Once a new setting is changed, you can use the Save function to
accept the changes. You must then reset the device to save the settings to flash
memory.

To reset the device:

1. Right-click a desired device to display the settings menu.
2. Select Reset Device.

Figure 3.18 Reset Device

The device resets. Once the process is complete, the modbus router displays under
the Serial Device Server listing once again.
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4Managing Modbus 
Router



4.1 Overview
An EKI modbus router can be configured through a web interface. By using a stan-
dard web browser, the same procedure as with the Windows configuration utility can
be used. In the browser’s address field, enter the IP Address of your EKI modbus
router. The default IP setting is 192.168.1.1, but you should use the IP which you
have previously assigned for this device. Once the IP is entered, you will be pre-
sented with the following windows.

4.2 Accessing the Web Page

4.2.1 Accessing the Web Page via Configuration Utility
To access the web page via configuration utility:

1. Select ETH2 under the desired device.
2. Click Launch Browser.

Figure 4.1 Accessing the Web Page via Configuration Utility

Note! Before using the web-based configuration, make sure your host PC 
Ethernet network IP domain is as same as the modbus router, or it can 
establish the TCP connection with the modbus router.

Note! It is recommended that you use Microsoft Internet Explorer 7.0 or 
higher.
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4.2.2 Accessing the Web Page via Web Browser
Once the device is installed and connected, power on the device. The following infor-
mation guides you through the logging in process.

1. Launch your web browser on the PC.
2. In the browser’s address bar, type the device’s default IP address (Eth1: 

192.168.0.1, Eth2: 192.168.1.1).
The main interface displays.

4.2.3 Changing Default Password
In keeping with good management and security practices, it is recommended that
you change the default password as soon as the device is functioning and setup
correctly. The following details indicate the necessary steps to change the default
password.

To change the password:

1. Navigate to System Management > Administration.
2. In the Password field, type in the new password. Re-type the same password in 

the Confirmation field.
3. Click Apply to change the current settings.

Figure 4.2 Changing a Default Password
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4.3 Overview
The Overview menu lists information pertaining to the system, such as Hostname,
Model, Firmware version, and more. The information is for review only. To modify the
device information, see the respective item within the user interface.

The following figures represent multiple supported devices. Some interface screens
may represent specific device models.

To access this page, click Overview.

Figure 4.3 Overview

The following table describes the items in the previous figure.

Item Description

System

Hostname Displays the host name of the device.

Model Displays the model name of the device.

Firmware Version Displays the current firmware version of the device.

Local Time Displays the current time.

Uptime Displays the accumulated time for continuous operation.

Network

WAN Status Displays the WAN information.

LAN Status Displays the LAN information.

DHCP Leases The ensuing table for DHCP Leases settings are informational only: 
Hostname, IPv4-Address, MAC-Address and Leasetime remaining.
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4.4 LAN and DHCP
To access this page, click LAN and DHCP.

Figure 4.4 LAN and DHCP

The following table describes the items in the previous figure.

Item Description

LAN

IPv4 Address Enter a value to specify the IP address of the interface.
The default is 192.168.1.1.

IPv4 Netmask Enter a value to specify the IP subnet mask for the interface.
The default is 255.255.255.0.

DHCP Server

DHCP Server Click the radio button to designate the DHCP server function type.
When a new DHCP server mode is selected, the router requires a 
system restart for the new mode to take effect.

Start Enter a value to specify the start number of subscribers.
The default is 100.

Limit Enter a value to specify the limited number of subscribers. This 
functionality allows an Internet service provider (ISP) to limit the 
number of leases available to clients per household or connection.
The default is 150.

Leasetime Set the valid time lease of IP address obtained by DHCP.
The default is 12 hours.

DNS Strict-order Check to enable or disable By default, dnsmasq will send queries to 
any of the upstream servers it knows about and tries to favor servers 
that are known to be up. Setting this flag forces dnsmasq to try each 
query with each server strictly in the order they appear in the device.
The default is Disable.

Custom Primary DNS 
Server

Enter a value to specify the DNS server for the interface.
The default is none.
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4.5 WAN
To access this page, click WAN.

Figure 4.5 WAN

The following table describes the items in the previous figure.

Custom Secondary 
DNS Server

Enter a value to specify the DNS server for the interface.
The default is none.

Apply Click Apply to save the values and update the screen.

Item Description

Item Description

Protocol Click the drop-down menu to select the WAN IP Address Setting 
mode: static IP or DHCP client.

IPv4 Address Enter a value to specify the IP address of the interface.
The default is 192.168.0.1.

IPv4 Netmask Enter a value to specify the IP subnet mask for the interface.
The default is 255.255.255.0.

IPv4 Gateway Enter a value to specify the default gateway for the interface.
The default is 192.168.0.254.

Custom DNS 
Server 1

Enter a value to specify the DNS server for the interface.
The default is none.

Custom DNS 
Server 2

Enter a value to specify the DNS server for the interface.
The default is none.

Apply Click Apply to save the values and update the screen.
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4.6 VPN Passthrough
To access this page, click VPN Passthrough.

Figure 4.6 VPN Passthrough

The following table describes the items in the previous figure.

4.7 Port Configuration

4.7.1 Modbus Settings
To access this page, click Port Configuration > Modbus Settings.

Figure 4.7 Port Configuration > Modbus Settings

The following table describes the items in the previous figure.

Item Description

PPTP Passthrough Click the radio button to enable the PPTP passthrough function.

L2TP Passthrough Click the radio button to enable the L2TP passthrough function.

IPSec Passthrough Click the radio button to enable the IPSec passthrough function.

Apply Click Apply to save the values and update the screen.

Item Description

Listen Port for Slave 
Mode

Enter a value to identify the channel for remote initiating connections. 
The default value is 502.

Apply Click Apply to save the values and update the screen.
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4.7.2 Port

4.7.2.1 Basic
To access this page, click Port Configuration > Port > Basic.

Figure 4.8 Port Configuration > Port > Basic

The following table describes the items in the previous figure.

Item Description

Type Click the drop-down menu to select a serial interface: RS232, RS422 
or RS485.

Baud Rate Click the drop-down menu to select a value to specify the baud rate. 
The value should conform to the current transmission speeds of 
connected devices when setting the baud rate.

Parity Click the drop-down menu to select the parity: None, Odd, Even, Mark 
or Space.

Data Bits Click the drop-down menu to select the data bits: 5, 6, 7, or 8.

Stop Bits Click the drop-down menu to select the stop bits: 1, 1.5 or 2.

Flow Control Click the drop-down menu to select the flow control mode: None, 
XOn/XOff or RTS/CTS.

Apply Click Apply to save the values and update the screen.
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4.7.2.2 Operation
To access this page, click Port Configuration > Port > Operation.

Figure 4.9 Port Configuration > Port > Operation

The following table describes the items in the previous figure.

Item Description

Mode Click the drop-down menu to select the port configuration mode: 
Modbus Slave Mode.

Protocol Select the protocol of the Slave Mode or Master Mode (RTU or 
ASCII).

Slave Timeout(ms) Specify the time duration in milliseconds for the EKI-122xR-CE Series 
to wait for a response after it has issued a command while using 
Modbus/RTU or Modbus ASCII. After the timeout is expired and no 
response is received, the EKI-122xR-CE Series will regard the 
command as failed. Note that the timeout for the host PC must be 
greater than the timeout setting here specified, otherwise an error will 
occur.

Peer for Receiving Data

Peer Number Click the drop-down menu to select the number of network device 
which you want to connect.

Apply Click Apply to save the values and update the screen.
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4.8 OpenVPN

4.8.1 Tunnel
To access this page, click OpenVPN > Tunnel.

Figure 4.10 OpenVPN > Tunnel

The following table describes the items in the previous figure.

Item Description

Status Display the current status of the tunnel.

Tunnel 1 Click the radio button to enable or disable the tunnel.

Protocol Click the drop-down menu to select the tunnel protocol: UDP, TCP 
Server or TCP Client.

Port Enter a value to import or export certificate (CRL).

Remote IP Address Enter a value to specify a remote IP address.

Remote Subnet Enter a value to specify a remote subnet.

Remote Subnet 
Mask

Enter a value to specify a remote subnet mask.

Server Network Enter a value to specify a server netmask.

Server Netmask Enter a value to specify a server network.

Redirect Gateway Check the box to initiate the redirect gateway feature. When redirect-
gateway is used, OpenVPN clients will route DNS queries through the 
VPN, and the VPN server will need handle them.

Local Interface IP 
Address

Enter a value to specify a ping interval.
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4.9 Filter

4.9.1 Filter Settings
To access this page, click Filter > Filter Settings.

Figure 4.11 Filter > Filter Settings

The following table describes the items in the previous figure.

Remote Interface IP 
Address

Enter a value to specify a local interface IP address.

Ping Interval Enter a value to specify a local interface IP address.

Ping Timeout Enter a value to specify a ping timeout period.

Renegotiate Interval Enter a value to specify an interval to renegotiate data channel key.

Max Fragment Size Enter a value to specify the maximum fragment size for backups and 
restores.

Compression Click the radio button to enable Compression.

NAT Rules Applied Click the drop-dwon menu to specify the authenticate mode.

Authenticate Mode Enter a value to specify the shared key or TLS-AUTH static password.

Pre-shared Secret Click Browse to select the Pre-shared key file which you can use for 
every authentication mode.

CA Certificate Click Browse to select the CA certificate file which you can use for the 
username/password and X.509 Certificate authentication modes.

DH Parameters Click Browse to select the DH parameter file e which you can use for 
X.509 Certificate authentication in the server mode.

Local Certificate Click Browse to select the local certificate file. Use this authentication 
certificate for the X.509 Certificate authentication mode.

Local Private Key Click Browse to select the local private key file. Use the key for the 
X.509 Certificate authentication mode.

Username Enter the name of the new user entry.

Password Enter the character set for the define password type.

Extra Options Enter a string to specify additional parameters for the OpenVPN 
tunnel, such as DHCP options. The parameters are proceeded by two 
dashes.

Apply Click Apply to save the values and update the screen.

Item Description

Item Description

Filter Click the radio button to enable the filter function.

Apply Click Apply to save the values and update the screen.
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4.9.2 Filter Rules
To access this page, click Filter > Filter Rules.

Figure 4.12 Filter > Filter Rules

The following table describes the items in the previous figure.

4.10 Port Forward

4.10.1 Port Forwarding
To access this page, click Port Forward > Port Forwarding.

Figure 4.13 Port Forward > Port Forwarding

The following table describes the items in the previous figure.

4.10.2 DMZ
To access this page, click Port Forward > DMZ.

Figure 4.14 Port Forward > DMZ

The following table describes the items in the previous figure.

Item Description

Add Click Add to add a new filter rule.

Apply Click Apply to save the values and update the screen.

Item Description

Add Click Add to add a new port forwarding setting.

Apply Click Apply to save the values and update the screen.

Item Description

DMZ Click the radio button to enable or disable the DMZ function.
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4.11 QoS
The QoS function allows you to configure settings for the router QoS interface and
how the router connects to a remote server to get services.

4.11.1 QoS Settings
The QoS Settings allows you to set up the QoS function.

To access this page, click QoS > QoS Settings.

Figure 4.15 QoS > QoS Settings

The following table describes the items in the previous figure.

IP Enter a value to specify the IP address of the DMZ.

Apply Click Apply to save the values and update the screen.

Item Description

Item Description

QoS Click the radio button to enable the QoS function.

Download Speed 
(kbit/s)

Enter a value to specify the download speed. The default speed is 
8291 kbit/s.

Upload Speed (kbit/s) Enter a value to specify the upload speed. The default speed is 2048 
kbit/s.

Apply Click Apply to save the values and update the screen.
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4.11.2 QoS IP Base Rules
The QoS rule specifies what actions are to be taken with the data packets. It specifies
the source and destination of the communication, what services can be used, at what
times, whether to log the connection and the logging level.

To access this page, click QoS > QoS IP Base Rules.

Figure 4.16 QoS > QoS IP Base Rules

The following table describes the items in the previous figure.

4.11.3 QoS Protocol Base Rules
The QoS Protocol Base Rule menu allows you to forward the device which works in
tandem with signaling protocols to ensure end-to-end QoS.

To access this page, click QoS > QoS Protocol Base Rules.

Figure 4.17 QoS > QoS Protocol Base Rules

The following table describes the items in the previous figure.

Item Description

Add Click Add to add a new QoS IP base rule.

Apply Click Apply to save the values and update the screen.

Item Description

Add Click Add to add a new QoS protocol base rule.

Apply Click Apply to save the values and update the screen.
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4.12 Static Routes
A static route provide fixed routing path through the network. It is manually configured
on the router and must be updated if the network topology was changed recently.
Static routes are private routers unless they are redistributed by a routing protocol.

4.12.1 Static IPv4 Routes
To access this page, click Static Routes > Static IPv4 Routes.

Figure 4.18 Static Routes > Static IPv4 Routes

The following table describes the items in the previous figure.

Item Description

Add Click Add to add a new static IPv4 route.

Apply Click Apply to save the values and update the screen.
54 EKI-122xR-CE Series User Manual



4.13 Diagnostics
Through the Diagnostics function configuration of settings for the router diagnostics
is available.

To access this page, click Diagnostics.

Figure 4.19 Diagnostics

The following table describes the items in the previous figure.

Item Description

IP Address or 
Hostname

Enter the IP address or host name of the station to ping. The initial 
value is blank. The IP Address or host name you enter is not retained 
across a power cycle. Host names are composed of series of labels 
concatenated with periods. Each label must be between 1 and 63 
characters long, maximum of 64 characters.

Ping Click Ping to display the ping reply format.

IP Address or 
Hostname

Enter the IP address or host name of the station to traceroute. The 
initial value is blank. The IP Address or host name you enter is not 
retained across a power cycle. Host names are composed of series of 
labels concatenated with periods. Each label must be between 1 and 
63 characters long, maximum of 64 characters.

Traceroute Click Traceroute to display the traceroute reply format.

Apply Click Apply to save the values and update the screen.
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4.14 Status
Status contains Routes and Syslog.

4.14.1 Routes
To access this page, click Status > Routes.

Figure 4.20 Status > Routes

4.14.2 Syslog
Users can check the history in the Syslog page.

To access this page, click Status > Syslog.

Figure 4.21 Status > Syslog
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4.15 System Management

4.15.1 Administration
The Change Password function allows you to easily update your current password
from a single menu.

To access this page, click Management > Administration.

Figure 4.22 Management > Administration

The following table describes the items in the previous figure.

If you want to disable the password protection, change the password to the default
option None (leave the password column blank). Make sure you apply and reboot the
system (Management > Reboot) to save the updates.

4.15.2 Backup / Flash Firmware
To access this page, click Management > Backup / Flash Firmware.

Figure 4.23 Management > Backup / Flash Firmware

The following table describes the items in the previous figure.

Item Description

Password Enter the character set to define a password.

Confirmation Retype the password entry to confirm the profile password.

Submit Click Submit to save the values and update the screen.

Item Description

Backup / Restore

Download Backup Click Backup to backup configuration from the device.

Reset to Defaults Click Reset to have all configuration parameters reset to their factory 
default values. All changes that have been made will be lost, even if 
you have issued a save.
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4.15.3 System
To access this page, click Management > System.

Figure 4.24 Management > System

The following table describes the items in the previous figure.

Restore Backup Click Browse to select the configuration file and click Upload Archive 
to restore configuration to the device.

Flash new firmware image

Image Click Browse to select the firmware file and click Flash image to 
upgrade the firmware.

Item Description

Item Description

System

Local Time Displays the current time. Click Sync with browser and synchronize 
the time on the device with the local PC.

Hostname Enter the device name: up to 31 alphanumeric characters.

Timezone Click the drop-down menu to select a system time zone.

NTP Setting

NTP Click the radio button to enable or disable the NTP.

Provide NTP Server Click the radio button to enable or disable the provide the NTP server.

NTP Server 
Candidates

Enter the address of the NTP server. This is a text string of up to 64 
characters containing the encoded unicast IP address or hostname of 
a NTP server. Unicast NTP requests will be sent to this address. If this 
address is a DNS hostname, then that hostname should be resolved 
into an IP address each time a NTP request is sent to it.

Apply Click Apply to save the values and update the screen.
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4.15.4 Reboot Device
To access this page, click Management > Reboot Device.

Click Reboot to reboot the modbus router. Any configuration changes you have
made since the last time you issued a save will be lost.

Figure 4.25 Management > Reboot Device
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